Global Search Slowness

Incident Report for Help Scout

Resolved

This issue has been resolved. Global search and tag management are performing normally again. We're sorry for the disruption this caused. If you're still experiencing issues, please email help@helpscout.com, and we'd be happy to assist. Again, thank you for your patience while we got to the bottom of this.
Posted Jun 18, 2026 - 06:45 EDT

Update

Our engineering team has made progress on the issue affecting global search: search results are recovering for affected customers. Tag management may still be affected for some customers; our team is working on a resolution. We'll post another update as soon as we have more.
Posted Jun 18, 2026 - 04:47 EDT

Update

Our engineering team has resumed work on the issue affecting global search this morning. Some customers may continue to see slower-than-usual or incomplete search results while this is in progress. We'll share another update as soon as we have more.
Posted Jun 18, 2026 - 02:22 EDT

Update

Our team continues to address the issue affecting global search and has scheduled further work for tomorrow morning (CET) during a low-traffic window. Some customers may experience intermittent search slowness until this is complete.
Posted Jun 17, 2026 - 11:43 EDT

Update

Our team is continuing to work on the issue affecting global search. Some customers may still see slower-than-usual results in the meantime. We'll post another update as soon as we have more to share.
Posted Jun 17, 2026 - 09:11 EDT

Identified

Some customers may be seeing slower-than-usual results or occasional failures when using global search. We've identified the cause, and our engineering team is actively working on a fix. We'll post an update here as soon as the situation improves.
Posted Jun 17, 2026 - 07:46 EDT
This incident affected: Web App, Mailbox counts, folders, reports, search results and Public APIs (Inbox API).