Connections Issues

Incident Report for Help Scout

Resolved

Performance is now stable across the board at Help Scout - all issues caused by the outage at one of our service providers have now been resolved. Everything should be working as normal in your account once again. Thank you for your patience while we investigated this!
Posted Oct 20, 2025 - 17:46 EDT

Monitoring

Performance at Help Scout seems to be improved from earlier. The outage at our service provider is still not fully resolved, so some issues may still occur. We'll post more updates as soon as we know more, but for now, things seem to be on the mend.
Posted Oct 20, 2025 - 15:58 EDT

Update

Performance is continuing to improve at Help Scout, but we are still seeing some issues as a result of an outage at one of our service providers. You may still encounter error messages & slow loading across the board while working from your account. Until our service provider announces the issue has been fully resolved, we'll keep posting updates here to keep you up to date.
Posted Oct 20, 2025 - 15:31 EDT

Update

While we have seen some small improvements, we are still seeing loading & performance issues across Help Scout as a result of an outage with one of our service providers. We'll continue to check in here with updates as we get them. We appreciate your patience as this outage continues!
Posted Oct 20, 2025 - 14:48 EDT

Update

We're seeing some improvements in today's issue, but it continues to impact loading & performance across all areas of Help Scout. We are monitoring this with our service provider, and we will continue to share updates here as soon as we have them.
Posted Oct 20, 2025 - 14:03 EDT

Update

We're still seeing issues in Help Scout as a result of an ongoing outage with one of our service providers. We are continuing to monitor and will provide updates here as soon as we have more to share.
Posted Oct 20, 2025 - 13:21 EDT

Update

We are still seeing issues with accessing Help Scout while we attempt to fix the issue and work with our service provider to restore functionality. We will provide additional updates as we make progress.
Posted Oct 20, 2025 - 12:39 EDT

Identified

We’ve identified issues affecting our app as a result of disruption with one of our cloud infrastructure providers. We are monitoring their recovery closely and will share an update as soon as we know more.
Posted Oct 20, 2025 - 12:04 EDT

Update

We are continuing to investigate this issue. Thank you for your patience as we get things working smoothly again.
Posted Oct 20, 2025 - 11:13 EDT

Investigating

We're looking in to reports of slow page loads and problems loading Help Scout. We'll update here when we have more information.
Posted Oct 20, 2025 - 10:45 EDT
This incident affected: Web App.