Connections Issues

Incident Report for Help Scout

Resolved

Performance is stable across the board, so we're closing this out. We'll continue to monitor all services over the next few hours.
Posted Mar 02, 2026 - 12:00 EST

Monitoring

Help Scout is coming back online. We'll continue to monitor for a bit longer before wrapping this up.
Posted Mar 02, 2026 - 11:50 EST

Identified

We’ve identified the root cause and we're making progress - you may continue to see slow loading times and variable accessibility.
Posted Mar 02, 2026 - 11:28 EST

Investigating

We're investigating reports of Help Scout not loading. We will update here when we have more information.
Posted Mar 02, 2026 - 11:06 EST
This incident affected: Web App and Beacon.