Slow Page Loads
Incident Report for Help Scout
Resolved
We've resolved the issue causing lagging in the app, and have been monitoring. Everything is up and running as usual again. Thanks for your patience today!
Posted Aug 15, 2022 - 10:43 EDT
Monitoring
Our engineers have put a fix in place and the app is operating at full speed.

We'll continue to monitor, and apologies for the trouble today!
Posted Aug 15, 2022 - 10:10 EDT
Identified
We've identified the cause of the issues causing the slowness across Help Scout this morning and are implementing a solution. We'll keep you informed on our progress -- thanks for your patience.
Posted Aug 15, 2022 - 09:50 EDT
Update
Our engineers continue investigating the root cause for the slowness we've been experiencing while loading the app. We will update this page once we have further information.
Posted Aug 15, 2022 - 09:30 EDT
Update
Our team continues to investigate the slow page loads across the app. We'll update here when we have more information.
Posted Aug 15, 2022 - 08:53 EDT
Investigating
We're looking in to reports of slow page loads across the app. Some customers may notice delays when attempting to move around the app, or load conversations. We'll update here when we have more information.
Posted Aug 15, 2022 - 08:20 EDT
This incident affected: Web App and Mailbox counts, folders, reports, search results.