Mailbox counts, folders, reports, search results

Incident Report for Help Scout

Resolved

Inbox (specifically View) behavior is stable across the board, so we're closing this out. Thank you for your patience while we worked on this one!
Posted Sep 22, 2026 - 15:32 EDT

Monitoring

Our Team identified a backend issue impacting Views and folder counts. A fix is now in place and Inbox will take some time to normalize. Conversations should start to move into the correct views as we work through the backlog. We will continue monitoring.
Posted Sep 22, 2026 - 14:56 EDT
This incident affected: Mailbox counts, folders, reports, search results.