Connections and Chat Issues
Incident Report for Help Scout
Resolved
Performance is stable and we're closing this out. We appreciate your patience!
Posted May 16, 2022 - 13:11 EDT
Update
We are continuing to investigate this issue.
Posted May 16, 2022 - 12:16 EDT
Investigating
We're looking in to reports of slow page loads across the app and issues with Chat. We'll update here when we have more information.
Posted May 16, 2022 - 12:14 EDT
This incident affected: Web App, Beacon, Mailbox counts, folders, reports, search results and Public APIs (Mailbox API 2.0).