Android App Issues

Incident Report for Help Scout

Resolved

We have resolved the issue with Help Scout Android app with a new update. You will need to update to the latest version of the app to see the changes. Thank you again for your patience while we worked to resolve this!
Posted 18 days ago. Mar 18, 2025 - 12:15 EDT

Identified

Our mobile engineers have identified the problem and we are working to get the Android app back up and running. Thank you for bearing with us.
Posted 18 days ago. Mar 18, 2025 - 11:29 EDT

Investigating

We’ve been alerted to a problem with Help Scout's Android app. Users are unable to load the app. Our mobile engineers are investigating and we'll be posting updates here.
Posted 18 days ago. Mar 18, 2025 - 11:05 EDT
This incident affected: Web App.