Views Loading Issues

Incident Report for Help Scout

Resolved

Our engineers have resolved the root cause of the issue with Views. They should be loading now as normal. We're closing this out and our engineers will continue to monitor. Sorry for the trouble today!
Posted May 26, 2025 - 12:13 EDT

Identified

Our engineers have identified the root cause of the issue with Views and are working on resolving it. Thank you for your patience.
Posted May 26, 2025 - 12:08 EDT

Investigating

We're looking into connection errors that could be affecting loading conversations from the inbox views. We'll update here when we have more information!
Posted May 26, 2025 - 12:02 EDT
This incident affected: Web App.