Email Delays
Incident Report for Help Scout
Resolved
Our engineers have now resolved the issues we were experiencing, so we're now we're closing this one out. Apologies for the trouble! And please do let us know if you continue having issues, and we'll continue investigating.
Posted Oct 06, 2023 - 05:05 EDT
Identified
We're making progress! Our engineers have identified the issue and are working to restore email delivery services. We'll continue to update here as we make progress.
Posted Oct 06, 2023 - 04:41 EDT
Update
Our engineers are still investigating this issue, so email delivery might still be delayed for some customers until we're in the clear. We'll post more information here as soon as we have it.
Posted Oct 06, 2023 - 04:32 EDT
Investigating
We're investigating a problem with email delivery. Your Help Scout mailbox might be slow to update with new messages until we're in the clear. We'll post more information here as soon as we have it.
Posted Oct 06, 2023 - 03:53 EDT
This incident affected: Email Processing.