Inbound Email Delays
Incident Report for Help Scout
Resolved
Email queues are just about empty, so we're closing this one out. Apologies for any trouble!
Posted Jun 03, 2022 - 09:58 EDT
Investigating
We're investigating a problem with inbound email delivery. Your Help Scout mailbox might be slow to update with new messages and replies until we're in the clear. We'll post more information here as we have it.
Posted Jun 03, 2022 - 09:37 EDT
This incident affected: Email Processing.