Connection Issues
Incident Report for Help Scout
Resolved
Performance is stable across the board, so we're closing this out. We'll continue to monitor all services over the next few hours.
Posted Sep 19, 2024 - 12:12 EDT
Monitoring
The web-app was temporarily down between 15:30 - 15:34 UTC. Help Scout should now be loading correctly, though page loads might be slow as we continue to recover.
Posted Sep 19, 2024 - 11:54 EDT
This incident affected: Web App.