Connections Issues

Incident Report for Help Scout

Resolved

The earlier disruption with one of our cloud providers has been fully resolved. Help Scout services are stable, and we’ve confirmed normal performance across the platform. We’ll continue routine monitoring, but no further impact is expected.
Thanks for your patience while this issue was resolved.
Posted Oct 20, 2025 - 08:37 EDT

Monitoring

Our infrastructure provider is reporting significant recovery, and most Help Scout services are now operating normally.
We'll continue to monitor the situation and will share an update as soon as possible.
Posted Oct 20, 2025 - 06:25 EDT

Identified

We’ve identified the connectivity issues affecting our app as stemming from a disruption with one of our cloud infrastructure providers. Our team is monitoring their recovery closely. We’ll share an update as soon as we know more.
Posted Oct 20, 2025 - 05:50 EDT
This incident affected: Web App.