Degraded Performance & Slow Loading Issues

Incident Report for Help Scout

Resolved

Our engineers have identified and resolved the issue, so load times should now be back to normal once again. Thank you for your patience while we worked on this one!
Posted Sep 16, 2025 - 05:06 EDT

Investigating

We're investigating reports of slow loading and general sluggishness across the web app. You may notice longer-than-usual load times and delays when working from Help Scout. We will post here again as soon as we have more to share.
Posted Sep 16, 2025 - 04:18 EDT
This incident affected: Web App.