Inbound Email Delivery
Incident Report for Help Scout
Resolved
We've identified the source of the issue and have implemented a fix. We're working to process all missed emails and they should appear in mailboxes within the next couple of hours. New inbound emails should be processed normally moving forward. We're sorry for the trouble today!
Posted Jul 26, 2022 - 15:14 EDT
Investigating
We're investigating an issue with inbound email delivery. Your Help Scout mailbox might be slow to update with new messages and replies until we're in the clear. We'll post more information here as we have it.
Posted Jul 26, 2022 - 15:00 EDT
This incident affected: Email Processing.