Closed Folder Issues

Incident Report for Help Scout

Resolved

Our engineers have found the issue causing Closed Conversations not to display in the Closed Folder, and this has now been resolved, You should now find all of those Conversations in the Closed Folder as normal. Thanks for your patience while we worked on getting this one fixed up!
Posted Mar 12, 2026 - 13:59 EDT

Investigating

Our team has identified an issue with the Closed Folder. Recently Closed Conversations are not being added to the Folder, starting around 8am ET. This does not impact delivery - emails are still being sent without issue. We'll post again once we have an update on this.
Posted Mar 12, 2026 - 13:36 EDT
This incident affected: Mailbox counts, folders, reports, search results.