Inbound Email Delay and Sluggish Behavior Across Help Scout

Incident Report for Help Scout

Resolved

Alright folks, all services are stable so we're closing this out. Thanks for your patience and apologies for the disruption today!
Posted May 07, 2026 - 22:05 EDT

Monitoring

In-app performance has recovered in Help Scout and any delayed inbound email should now be delivered. We're continuing to monitor this situation as our third-party provider is still experiencing degraded performance. We'll continue to monitor that situation and will post updates as they come.
Posted May 07, 2026 - 21:35 EDT

Identified

Due to an outage with one of our third-party service providers, inbound email delays and other sluggishness around the app may continue. We're closely monitoring updates from our provider and working to improve performance as quickly as possible.
Posted May 07, 2026 - 21:21 EDT

Investigating

We're looking into a few issues that are currently impacting performance around several areas of Help Scout. Things like inbound email, your Closed folder, other Workflows folders, message counts/previews, search results, and potentially page loads. We'll continue to update as we make progress! Thanks for your patience.
Posted May 07, 2026 - 20:43 EDT
This incident affected: Web App, Email Processing, and Mailbox counts, folders, reports, search results.