Connection Issues

Incident Report for Help Scout

Resolved

The team has confirmed that the access issues have been fully resolved, and this incident is now closed. Thank you again for your patience!
Posted Apr 20, 2026 - 11:04 EDT

Identified

Our engineering team has identified intermittent access issues with the web app. We will update here once everything has been confirmed as resolved. Sorry for any inconvenience, and thank you for your patience.
Posted Apr 20, 2026 - 10:52 EDT
This incident affected: Web App.