Some users experiencing outbound email delivery failures
Incident Report for Help Scout
Resolved
Our engineers identified the root of the problem preventing some outbound emails from being delivered. Everything should be back up and running as expected now. If you received any bounce notifications, you can resend those emails now. Apologies for the disruption!
Posted Jan 18, 2024 - 19:11 EST
Investigating
We've received reports of some outbound emails getting bounced or quarantined, which seems to be related to how Help Scout's email domain is being handled by some email providers. Our engineers are investigating now.
Posted Jan 18, 2024 - 18:42 EST
This incident affected: Email Processing.