Slow page loads
Incident Report for Help Scout
Resolved
Page load times should be back to normal, and the web app should be responsive as usual. We're closing this out, sorry for the trouble today!
Posted Sep 19, 2022 - 10:07 EDT
Identified
We've identified an issue with a recent deployment and have a fix on the way. We're seeing some improvement with the slow page loads, but it may still be occurring intermittently.
Posted Sep 19, 2022 - 09:49 EDT
Investigating
We’ve been alerted to a problem with Help Scout - we’re seeing slowness across the board, and are investigating.
Posted Sep 19, 2022 - 09:30 EDT
This incident affected: Web App.