Connection and Chat Issues
Incident Report for Help Scout
Resolved
We've resolved the issue causing lagging in the app, and have been monitoring for the past hour. Everything appears to be up and running as usual again. Thanks for your patience today!
Posted May 16, 2022 - 17:49 EDT
Identified
We've identified an issue causing lagging in the app and should have things running smoothly again shortly.
Posted May 16, 2022 - 16:50 EDT
This incident affected: Web App and Beacon.