Web App Connection Timeouts

Incident Report for Help Scout

Resolved

We are no longer seeing any errors with the Help Scout web app and are confident that we've resolved the issue.

We're sorry for any trouble this has caused, and thank you for your patience!
Posted Aug 07, 2025 - 18:15 EDT

Monitoring

The Help Scout web application is experiencing sporadic connection failures for some customers, resulting in long page load times and, in some cases, a “no healthy upstream” error. We believe we've identified the issue and have seen things recover, but will continue to monitor the issue until fully resolved.
Posted Aug 07, 2025 - 17:09 EDT
This incident affected: Web App.