Beacon Issues

Incident Report for Help Scout

Resolved

Live Chat behavior is stable across the board, so we're closing this out. Thank you for your patience while we worked on this one!
Posted Aug 14, 2026 - 12:17 EDT

Update

Live Chat behavior is stable across the board, so we're closing this out. Thank you for your patience while we worked on this one!
Posted Aug 14, 2026 - 12:17 EDT

Monitoring

A fix is now in place, and Live Chat behavior is normalizing. Our Engineering Team is continuing to monitor the situation.
Posted Aug 14, 2026 - 11:13 EDT

Investigating

We’re currently investigating reports of issues with slow behavior and loading in Live Chat. We will continue to update as we have more information.
Posted Aug 14, 2026 - 10:59 EDT
This incident affected: Beacon.