Sidebar Apps loading intermittently

Incident Report for Help Scout

Resolved

We've monitored the fix we implemented and sidebar apps are now loading. Thanks for your patience as we investigated and fixed this issue.
Posted Mar 11, 2026 - 12:42 EDT

Monitoring

We've identified and fixed the issue that prevented sidebar apps from loading. We're continuing to monitor sidebar apps performance and we'll post an update here when the issue is fully resolved.
Posted Mar 11, 2026 - 12:34 EDT

Investigating

We’re aware that some customers are having issues with sidebar apps and apps are loading intermittently, or not loading at all. We're investigating the issue and we'll post an update here once we have additional information to share. Thanks for your patience and apologies for the disruption.
Posted Mar 11, 2026 - 12:12 EDT
This incident affected: Web App.