Connections Issues
Incident Report for Help Scout
Resolved
This incident has been resolved.
Posted May 16, 2022 - 11:25 EDT
Monitoring
The web-app is back online and we're currently monitoring the situation as things continue to recover.
Posted May 16, 2022 - 11:01 EDT
Investigating
We’re seeing reports of sporadic long page loads accompanied by timeouts when trying to access the web app. We're currently investigating and will share updates as we can.
Posted May 16, 2022 - 10:55 EDT
This incident affected: Web App and Email Processing.