Inbound Email Delays
Incident Report for Help Scout
Resolved
Performance is stable across the board and we're closing out this incident. Emails are processing messages in a timely manner as expected. Sorry for the trouble today, and please get in touch if you notice any continued problems.
Posted Jan 09, 2024 - 10:57 EST
Monitoring
We're continuing to clear the backlog of emails, all of which should be landing in your inboxes within the next half hour. We'll close this out when the backlog is clear. Thanks for your patience today.
Posted Jan 09, 2024 - 10:22 EST
Identified
We've identified the cause of the issue and are now clearing the backlog of messages to be delivered. We'll update again when the issue has been resolved.
Posted Jan 09, 2024 - 09:56 EST
Update
We are continuing to investigate the disruption to inbound email delivery. More updates as we have them, and apologies for the delays.
Posted Jan 09, 2024 - 09:47 EST
Investigating
We're investigating a problem with email delivery. Your Help Scout mailbox might be slow to update with new messages and replies until we're in the clear. We'll post more information here as we have it.
Posted Jan 09, 2024 - 09:14 EST
This incident affected: Email Processing and Mailbox counts, folders, reports, search results.