Connections Issues
Incident Report for Help Scout
Resolved
The team have discovered the cause of the issue and connection is now stable.
Posted Dec 07, 2022 - 10:36 EST
Update
We are continuing to investigate the root cause and will update once we have further information.
Posted Dec 07, 2022 - 09:44 EST
Investigating
We're looking into reports of slow page loads and connection timeouts across the app. Some customers may notice a long delay when attempting to send replies. We'll update here when we have more information.
Posted Dec 07, 2022 - 09:11 EST
This incident affected: Web App and Mailbox counts, folders, reports, search results.