Delayed Inbound Email
Incident Report for Help Scout
Resolved
A new SSL certificate has been issued and all new email should be processed as expected. If you are missing emails in your Help Scout mailbox(es) that were sent between April 8, 2023 00:00:00 UTC/GMT and April 10, 2023 05:10:00 UTC/GMT, you may need to manually forward them to your Help Scout mailbox address from your email provider directly.
Posted Apr 10, 2023 - 13:40 EDT
Identified
We're working with our provider to accelerate the issuance of a new SSL certificate. Customers should still keep an eye on their mail forwarders for any time-sensitive emails.
Posted Apr 10, 2023 - 12:10 EDT
Update
We've identified an issue with one of our SSL certs, and are actively working to rectify the issue. Customers using TLS encryption will be unable to connect and should check their mail forwarders directly for any time-sensitive email.
Posted Apr 10, 2023 - 11:38 EDT
Investigating
We're investigating a problem with email delivery. Your Help Scout mailbox might be slow to update with new messages and replies until we're in the clear. We'll post more information here as we have it.
Posted Apr 10, 2023 - 11:30 EDT
This incident affected: Email Processing.