Delays to Conversation Updates

Incident Report for Help Scout

Resolved

This issue has been resolved. Conversations and folders should now be up to date and working as expected. Apologies for the trouble!
Posted Sep 15, 2025 - 14:02 EDT

Investigating

We’ve been alerted to a problem with Help Scout and are investigating. You may see a delay in view counts updating and in merging conversations. We'll let you know when we have additional information.
Posted Sep 15, 2025 - 13:24 EDT
This incident affected: Email Processing.