Outgoing email delays, AI Draft delay, Docs errors
Incident Report for Help Scout
Resolved
Today around 2:35pm ET, Help Scout's outbound email service experienced delays in sending, and while attempting to retry those emails, some duplicate emails were sent out. During this time, there were also issues with AI Draft generation, accessing and loading the app, and loading Docs sites.

As of around 4:15pm ET, all services had been restored: outbound emails were processing as expected, AI Drafts starting generating, Docs sites were loading correctly, and the app performance was back to normal. We're sorry for the trouble today!
Posted Mar 06, 2024 - 16:53 EST
Monitoring
We've implemented a fix for the aforementioned issues, and the following areas are restored and operational: outbound email processing, app performance (login issues and lags are resolved), loading Docs sites, and AI draft generation. We're monitoring the resolution to ensure its' success and will move this incident to Resolved as soon as we can.
Posted Mar 06, 2024 - 16:23 EST
Identified
We’ve identified the issues and are actively working to resolve them. As of now, AI Drafts should begin generating and outbound emails should start sending. We’re still working to fully restore the outbound email service, and so we’ll post more details as we have them. We’re digging into the issues with loading Docs sites, and you may still notice lags in the app as we continue to resolve the issue. Thanks for your patience!
Posted Mar 06, 2024 - 15:49 EST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2024 - 15:22 EST
Investigating
We are currently investigating an issue that's causing delays in outbound email processing, AI drafts not generating, and Docs sites' SSL errors. As a result of the outbound email delays, duplicate emails may be sending. We will update this issue as soon as we have updates to share.
Posted Mar 06, 2024 - 15:14 EST
This incident affected: Web App, Docs Sites, Email Processing, Mailbox counts, folders, reports, search results, and AI Drafts.