Outbound Email and Draft Creation Issues

Incident Report for Help Scout

Resolved

Resolved - Our team has identified and resolved the issue. Outbound emails are being delivered again. Sorry for the trouble today, everyone.
Posted Mar 25, 2026 - 14:00 EDT

Investigating

We’re currently investigating reports of outbound email and draft creation issues. We will continue to update as we have more information.
Posted Mar 25, 2026 - 13:47 EDT
This incident affected: Email Processing.