Connections Issues

Incident Report for Help Scout

Resolved

Our team has identified and resolved the issue, and performance is now stable across the board; therefore, we're closing this out. We'll continue to monitor all services over the next few hours. Thank you for your patience while we resolved this!
Posted Feb 26, 2026 - 07:29 EST

Investigating

We're currently investigating reports of slow page loads and timeouts when accessing the web app. We’ll share an update as soon as we have more information.
Posted Feb 26, 2026 - 07:21 EST
This incident affected: Web App, Email Processing, and Mailbox counts, folders, reports, search results.