Help Scout access has now been restored for customers in the Philippines. We will continue to monitor the situation. If you're still experiencing any issues accessing the platform, please let us know.
Posted Mar 06, 2026 - 16:26 EST
Update
Our team continues to work on a fix for the issue causing Help Scout to be unavailable for some customers in the Philippines. We apologize for the downtime today and we'll post here again as soon as this has been resolved.
Posted Mar 06, 2026 - 15:49 EST
Update
Our team are still working on a fix for the issue causing Help Scout to be unavailable for some customers in the Philippines. We'll post here again as soon as this has been resolved.
Posted Mar 06, 2026 - 13:57 EST
Identified
We've identified the cause of the access issues for customers in the Philippines and are working on implementing a solution. We'll keep you informed on our progress -- thanks for your patience.
Posted Mar 06, 2026 - 12:55 EST
Investigating
Help Scout is currently unavailable for some customers in the Philippines. It appears to be regionally isolated and we're currently investigating the root cause.