Email Delays
Incident Report for Help Scout
Resolved
We're in the clear. All queued incoming emails have been processed, so we're closing this one out. Apologies for the trouble today!
Posted 19 days ago. Jun 27, 2019 - 14:46 EDT
Monitoring
The issue has been fixed! You should start to see incoming emails populating in your mailbox again. We'll post back once the queues are completely clear.
Posted 19 days ago. Jun 27, 2019 - 14:32 EDT
Investigating
We’ve been alerted to a problem with incoming emails. While all incoming emails are being queued for delivery, they aren't currently processing into mailboxes. Engineering is investigating and we'll update here as we know more.
Posted 19 days ago. Jun 27, 2019 - 14:27 EDT
This incident affected: Email Processing.