Connections Issues

Incident Report for Help Scout

Resolved

Our team has resolved the issue, and performance is now stable across the board; therefore, we're closing this out. We'll continue to monitor all services over the next few hours. Thank you for your patience while we resolved this!
Posted Dec 11, 2025 - 08:06 EST

Identified

The team has identified the root cause, and we're working on a fix, but it may take a bit longer before we can bring all services back online. We'll post an update when we've got more news to share.
Posted Dec 11, 2025 - 07:43 EST

Investigating

We're currently investigating reports of slow page loads and timeouts when trying to access the web app. We’ll share an update as soon as we have more information.
Posted Dec 11, 2025 - 07:06 EST
This incident affected: Web App, Docs Sites, and Beacon.