Email Delays
Incident Report for Help Scout
Resolved
A fix has been successfully applied, which should prevent this issue from happening again. Incoming emails that were queued up are now processing correctly in mailboxes. Thanks for your patience!
Posted 3 months ago. Jun 27, 2019 - 22:33 EDT
Update
Our engineers are applying a fix to resolve the backup. Previously delayed emails should now be in the mailboxes but customers may continue to see a delay with incoming emails while the fix is being applied.
Posted 3 months ago. Jun 27, 2019 - 21:50 EDT
Identified
Our engineers have identified the issue and are working on clearing the backlog. Incoming emails should get processed into mailboxes soon.
Posted 3 months ago. Jun 27, 2019 - 21:36 EDT
Investigating
We’re seeing reports of a delay with incoming emails. They are being queued for delivery, but the emails aren't currently processing into mailboxes. Our engineering team is investigating and we'll post further updates soon.
Posted 3 months ago. Jun 27, 2019 - 21:15 EDT
This incident affected: Email Processing.