Connections Issues
Incident Report for Help Scout
Resolved
Connectivity and Search Issues are resolved and operational. We'll be evaluating the root cause of this event to help prevent incidents like this in the future. We appreciate your patience today!
Posted May 04, 2022 - 14:57 EDT
Identified
Our teams have identified the problem and are working on implementing a fix. Service is slowly being restored, and we'll share another update when things are completely operational. We apologize for any trouble this has caused!
Posted May 04, 2022 - 14:22 EDT
Investigating
We're looking in to reports of slow page loads across the app. Some customers may notice a long delay when attempting to send replies. This could impact things like your Folders, Workflows, message counts/previews, and search results. We'll continue to update as we make progress!
Posted May 04, 2022 - 14:00 EDT
This incident affected: Web App and Mailbox counts, folders, reports, search results.