Issues with Email Delivery

Incident Report for Help Scout

Resolved

We are no longer seeing errors associated with sending and receiving emails from Google Workspace. Emails sent via Google OAuth may be delayed, but will be delivered to customers. If you continue to see any issues with email deliveries in Help Scout, please reach out to our team to further investigate.
Posted Jun 12, 2025 - 15:54 EDT

Update

We are seeing successful Google API calls, though there may be a delay in email deliveries. If you observe any bounced replies, you may try re-sending them. We will provide updates as we continue to monitor this issue.
Posted Jun 12, 2025 - 15:37 EDT

Monitoring

We are observing errors related to Google Workspace APIs. Customers who use Google Workspace and have connected their Help Scout inboxes to send via Google OAuth may find they are not able to send or receive email.
Posted Jun 12, 2025 - 15:18 EDT
This incident affected: Email Processing.