Delays with Inbox counts, folders, reports and search results

Incident Report for Help Scout

Resolved

Folder counts and updates in your Inbox should be working as expected again! Thanks for your patience today folks, we're going to close this one out.
Posted Jul 24, 2026 - 19:09 EDT

Update

We're still experiencing a bit of degraded performance around folder counts while the system continues to catch up. We appreciate your continued patience and will update you all just as soon as we've got this under control.
Posted Jul 24, 2026 - 18:45 EDT

Monitoring

Our team has implemented a fix for these issues impacting folder counts and Inbox performance. We're hoping to move this to Resolved soon, folks.
Posted Jul 24, 2026 - 18:30 EDT

Investigating

We’re currently investigating reports of issues with delayed Inbox folder counts, folders and search results. We will continue to update as we have more information.
Posted Jul 24, 2026 - 18:08 EDT
This incident affected: Mailbox counts, folders, reports, search results.