Help Desk API and Beacon Issues
Incident Report for Help Scout
Resolved
All services are stable, so we're closing this out. Today’s issues were caused by an unexpected database failover due to a connection issue with AWS, which knocked the Help Desk APIs and Beacon offline for 23 minutes. We made some configuration changes to help with reliability going forward. We're also digging in to figure out what's going on with AWS to prevent this from happening again. Sorry for the trouble today!
Posted 3 months ago. Aug 30, 2018 - 13:24 EDT
Update
All services are stable, so we're closing this out. Today’s issues were caused by an unexpected database failover due to a connection issue with AWS, which knocked the Help Desk APIs and Beacon offline for 23 minutes. We made some configuration changes to help with reliability going forward. We're also digging in to figure out what's going on with AWS to prevent this from happening again. Sorry for the trouble today!
Posted 3 months ago. Aug 30, 2018 - 13:22 EDT
Monitoring
Both Help Desk APIs, as well as the Beacon embed (and live chat) are back online and available to use. We'll continue to monitor for a bit longer before wrapping this up.
Posted 3 months ago. Aug 30, 2018 - 12:56 EDT
Investigating
The Help Desk API, Beacon, and live chat are unavailable at the moment. We're on it, and we'll post updates here as we have them.
Posted 3 months ago. Aug 30, 2018 - 12:35 EDT
This incident affected: Beacon, Mailbox API 1.0, Mailbox API 2.0, and Live Chat.