Search and Page Load Issues
Incident Report for Help Scout
Resolved
We have identified and corrected the cause of this issue. Folders, search results, and page loads should be performing as normal. Thank you for your patience!
Posted Apr 24, 2024 - 18:45 EDT
Investigating
We're looking into reports of slow loading across the app. Features like Search and folders may be slow to load. This should impact fewer than 10% of customers. We'll update here when we have more information.
Posted Apr 24, 2024 - 18:19 EDT
This incident affected: Mailbox counts, folders, reports, search results.