App Access Issues

Incident Report for Help Scout

Resolved

Access issues have been fully resolved, and this incident is now closed. Sorry for any inconvenience this caused, and thank you for your patience.
Posted Jul 09, 2026 - 13:15 EDT

Monitoring

The issues accessing Help Scout have resolved. Our Engineering Team is continuing to monitor the situation and investigate the cause.
Posted Jul 09, 2026 - 11:34 EDT

Investigating

We’re currently investigating reports of customers having trouble accessing Help Scout. We will continue to update as we have more information.
Posted Jul 09, 2026 - 10:59 EDT
This incident affected: Web App.