Degraded performance
Incident Report for Help Scout
Resolved
The web app is loading smoothly now. Thank you for your patience while we fixed this up!
Posted Jul 30, 2023 - 20:47 EDT
Monitoring
We've implemented a fix and seeing improvements across the app. We'll continue to monitor the situation closely.
Posted Jul 30, 2023 - 20:37 EDT
Investigating
We’re seeing some reports of slow page loads, timeouts and errors across the web app. Our team is looking into it!
Posted Jul 30, 2023 - 20:27 EDT
This incident affected: Web App.