Email Delays
Incident Report for Help Scout
Resolved
The issue has been identified and resolved. Previous outgoing emails, which had been delayed, have been processed now and new emails are being sent out as expected. Sorry for the trouble this evening!
Posted 2 months ago. Jul 07, 2019 - 21:09 EDT
Update
Our team is still investigating this issue and we'll post further updates as we have more information.
Posted 2 months ago. Jul 07, 2019 - 20:50 EDT
Investigating
We’ve been alerted to a problem with outgoing emails. Our engineering team is investigating.
Posted 2 months ago. Jul 07, 2019 - 20:10 EDT
This incident affected: Email Processing.