Email Delays
Incident Report for Help Scout
Resolved
Email queues are now clear, so we're closing this one out. Apologies for the trouble, friends!
Posted Mar 22, 2022 - 10:45 EDT
Identified
Our team has identified the issue and applied a fix. While email delivery is still delayed, we're working on getting the email queues clear as quickly as possible. We'll post an update as soon as we can confirm that the emails queues have drained.
Posted Mar 22, 2022 - 10:24 EDT
Investigating
We're investigating a problem with email delivery. Your Help Scout mailbox might be slow to send new replies until we're in the clear. We'll post more information here as we have it.
Posted Mar 22, 2022 - 10:09 EDT
This incident affected: Email Processing.