Connections Issues
Incident Report for Help Scout
Resolved
Full functionality restored, all services up and running correctly.

Around 3:10pm UTC, the Help Scout web application experienced connection failures, resulting in long page load times, and in some cases, pages failing to load at all. The result resulted in roughly 16 minutes of downtime. At roughly 3:25pm UTC, all services were back to normal. Very sorry for the trouble today!
Posted Mar 11, 2020 - 11:34 EDT
Monitoring
The web-app is back online, though page loads might be slow as we continue to recover. Workflows, inbound and outbound email, folder counts, search, and reports may be delayed until we're in the clear.
Posted Mar 11, 2020 - 11:28 EDT
Update
We're working as quickly as possible to restore services. We'll continue to update here as we make progress.
Posted Mar 11, 2020 - 11:22 EDT
Investigating
We’ve been alerted to a problem with Help Scout - we’re investigating.
Posted Mar 11, 2020 - 11:12 EDT
This incident affected: Web App.