Drafts Not Loading Properly

Incident Report for Help Scout

Resolved

Our engineers have fixed the issue preventing drafts from opening properly, and you should now be able to edit all of the drafts in your inbox. Thanks for your patience while we worked on getting this one fixed up!
Posted Mar 19, 2026 - 17:38 EDT

Identified

We've identified the cause of the issues with drafts are working on implementing a solution. We'll keep you informed on our progress and appreciate your patience.
Posted Mar 19, 2026 - 17:04 EDT

Investigating

We’re aware that some customers are having issues editing drafts on conversations. We're investigating the issue and will post an update here once we have additional information to share.
Posted Mar 19, 2026 - 16:50 EDT
This incident affected: Web App.