Folder and View Issues

Incident Report for Help Scout

Identified

We're still seeing delays, but we've identified the issue and we're working on a fix. We'll post a final update when services are back to normal.
Posted Mar 21, 2026 - 15:22 EDT

Update

We’re still investigating reports of issues with folders and views not displaying the correct conversations. We hope to have more information available soon.
Posted Mar 21, 2026 - 13:42 EDT

Investigating

We’re currently investigating reports of issues with [Feature]. We will continue to update as we have more information.
Posted Mar 21, 2026 - 12:39 EDT
This incident affects: Mailbox counts, folders, reports, search results.