Temporary Outage and Slow Loading across Help Scout

Incident Report for Help Scout

Resolved

Our team has resolved the issue that caused a temporary outage which impacted all areas of Help Scout from 2:10pm - 2:22p ET. The app should now be fully functional again. Apologies for the disruption today, folks!
Posted Nov 14, 2025 - 14:35 EST

Identified

We've identified the cause of the issues causing a partial outage and sluggish behavior across Help Scout this morning and are working on implementing a solution. We'll keep you informed on our progress -- thanks for your patience.
Posted Nov 14, 2025 - 14:27 EST
This incident affected: Web App.