Inbound Email Delays
Incident Report for Help Scout
Resolved
Our engineers have resolved the issue with inbound email. Emails will be arriving in your mailbox as expected, so we're closing this one out. Apologies for the trouble today!
Posted Oct 12, 2023 - 18:25 EDT
Identified
Our team has identified the problem causing inbound email to be delayed and is currently working on a fix. We'll post another update here once things are back up and running!
Posted Oct 12, 2023 - 17:55 EDT
Investigating
We're investigating a problem with email delivery. Your Help Scout mailbox might be slow to update with new messages and replies until we're in the clear. We'll post more information here as we have it.
Posted Oct 12, 2023 - 17:43 EDT
This incident affected: Email Processing.