Slow page loads
Incident Report for Help Scout
Resolved
Page load times should be back to normal now. We're closing this out, sorry for the trouble today!
Posted 3 months ago. Nov 06, 2024 - 10:13 EST
Investigating
We're looking into reports of slow page loads across the app. Some customers may notice a long delay when taking actions across Help Scout. We'll update here when we have more information.
Posted 3 months ago. Nov 06, 2024 - 09:58 EST
This incident affected: Web App.